summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-24 22:46:44 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:40 -0400
commit8b149214f389b9375ae1c1883e3dbec27f1d4361 (patch)
treefef392cc2ba0631339c38c22df5ccc65b6857074 /gnu
parent2f31302b78547ed8082d9d0a4d8108a4b53673ee (diff)
downloadguix-patches-8b149214f389b9375ae1c1883e3dbec27f1d4361.tar
guix-patches-8b149214f389b9375ae1c1883e3dbec27f1d4361.tar.gz
gnu: atkmm: Enable documentation.
* gnu/packages/gtk.scm (atkmm) [outputs]: Add new output "doc". [arguments]<#:configure-flags>[-Denable-documentation]: New flag. [arguments]<#:phases>['move-doc]: New phase. [native-inputs]: Add graphviz, doxygen. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b3498fa525..494c952013 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -74,6 +74,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages libffi)
@@ -1448,10 +1449,27 @@ library.")
(base32
"0wwr0663jrqx2klsasffd9wpk3kqnwisj1y3ahdkjdk5hzrsjgy9"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
(arguments
- `(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
+ `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ (list
+ "-Dbuild-documentation=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/doc")
+ (string-append doc "/share/doc"))
+ #t))))))
(native-inputs
- `(("m4" ,m4)
+ `(("dot" ,graphviz)
+ ("doxygen" ,doxygen)
+ ("m4" ,m4)
("mm-common" ,mm-common)
("perl" ,perl)
("pkg-config" ,pkg-config)