summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 11:30:26 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:38 -0400
commit31ed6339c47f03f382ab91982950302baa15c715 (patch)
tree3ca42179b4c385b01e66b241b7cfb933390a44d4 /gnu
parent1aed8b69842065b86e62072584230397eb15f32c (diff)
downloadguix-patches-31ed6339c47f03f382ab91982950302baa15c715.tar
guix-patches-31ed6339c47f03f382ab91982950302baa15c715.tar.gz
gnu: vala: Fix documentation.
* gnu/packages/gnome.scm (vala) [arguments]<#:phases>['patch-docbook-xml]: New phase. [native-inputs]: Add docbook-xml and docbook-xsl. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ca4484ce3e..92c46158ac 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4284,6 +4284,14 @@ passwords in the GNOME keyring.")
'(#:configure-flags '("--enable-coverage")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "doc/manual"
+ (substitute* '("manual.xml" "version.xml.in")
+ (("http://www.oasis-open.org/docbook/xml/4.4/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))))
+ #t))
(add-before 'check 'pre-check
(lambda _
(setenv "CC" "gcc")
@@ -4293,6 +4301,8 @@ passwords in the GNOME keyring.")
(string-append m "$PKG_CONFIG_PATH:"))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("docbook-xml" ,docbook-xml-4.4)
+ ("docbook-xsl" ,docbook-xsl)
("flex" ,flex)
("bison" ,bison)
("xsltproc" ,libxslt)