summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAdam Kandur <rndd@tuta.io>2020-11-15 22:25:37 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-15 22:25:37 +0100
commit204ac80ee762c8daec90e14dab41170687ef3b2b (patch)
treeab33429021a94977c394c4860fb8a0dd4db8cbc8 /gnu
parent0b1d58029ca45613ad2e42f1bc263ae9b161cd4d (diff)
downloadguix-patches-204ac80ee762c8daec90e14dab41170687ef3b2b.tar
guix-patches-204ac80ee762c8daec90e14dab41170687ef3b2b.tar.gz
gnu: Add emacs-parsec.
* gnu/packages/emacs-xyz.scm (emacs-parsec): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3eb8920812..637cdf0f0c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15009,6 +15009,34 @@ and @code{erc-send-modify-hook} to download and show images.")
(description "This package provides a list manipulation library for Emacs.")
(license license:gpl3+)))
+(define-public emacs-parsec
+ ;; Last release is too old (2016).
+ (let ((revision "0")
+ (commit "2cbbbc2254aa7bcaa4fb5e07c8c1bf2f381dba26"))
+ (package
+ (name "emacs-parsec")
+ (version (git-version "0.1.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cute-jumper/parsec.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g1s8s45g3kkbi3h7w0pmadmzdswb64mkdvdpg2lihg341kx37gm"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/cute-jumper/parsec.el")
+ (synopsis "Parser combinator library for Emacs Lisp")
+ (description
+ "Parsec is a parser combinator library for Emacs Lisp, similar to
+Haskell's Parsec library. It contains most of the parser combinators in
+Text.Parsec.Combinator, and more combinators can be added if necessary! Most
+of the parser combinators have the same behavior as their Haskell
+counterparts. Parsec also comes with a simple error handling mechanism so
+that it can display an error message showing how the parser fails.")
+ (license license:gpl3+))))
+
(define-public emacs-move-text
(package
(name "emacs-move-text")