summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-30 17:17:21 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-02 14:47:00 +0100
commit8d9e9f28574e51e6cc3a5f8efc9c80bd7185bd71 (patch)
treeace115d34a04f076a8ee59d41f42a2348e94d9d8 /gnu
parentb86be2ad1a947957f69c84c8d80c92cc568a7d7a (diff)
downloadguix-patches-8d9e9f28574e51e6cc3a5f8efc9c80bd7185bd71.tar
guix-patches-8d9e9f28574e51e6cc3a5f8efc9c80bd7185bd71.tar.gz
gnu: Add ruby-permutation.
* gnu/packages/ruby.scm (ruby-permutation): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 30a927779b..137b75a24f 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -649,6 +649,36 @@ and inspect the environment.")
(home-page "https://github.com/e2/nenv")
(license license:expat)))
+(define-public ruby-permutation
+ (package
+ (name "ruby-permutation")
+ (version "0.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "permutation" version))
+ (sha256
+ (base32
+ "13crwk2vfbzv99czva7881027dbcnidihmvx2jc58z2vm3bp9sl8"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-rakefile
+ (lambda _
+ (substitute* "Rakefile"
+ (("require 'rake/gempackagetask'")
+ "require 'rubygems/package_task'")
+ (("include Config") ""))
+ #t))
+ (replace 'check
+ (lambda _
+ (zero? (system* "ruby" "-Ilib" "test/test.rb")))))))
+ (synopsis "Library to perform operations with sequence permutations")
+ (description "This package provides a Ruby library to perform different
+operations with permutations of sequences, such as strings and arrays.")
+ (home-page "http://flori.github.io/permutation")
+ (license license:gpl2))) ; GPL 2 only
+
(define-public ruby-shellany
(package
(name "ruby-shellany")