summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-08 04:09:55 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-10-08 04:33:56 +0200
commit24fba107d156ef718ef6e1002a5a29a55dc2a275 (patch)
tree4ddac25cf1fdcdb1213f052dd1a076d67a4e4619 /gnu
parentb1baba38c0dd37a44c0be901421431cbdcca21e5 (diff)
downloadguix-patches-24fba107d156ef718ef6e1002a5a29a55dc2a275.tar
guix-patches-24fba107d156ef718ef6e1002a5a29a55dc2a275.tar.gz
gnu: camlzip: Update to 1.11.
* gnu/packages/ocaml.scm (camlzip): Update to 1.11.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 98846addf0..cad2e60f4e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1385,33 +1385,25 @@ other XUnit testing frameworks.")
(define-public camlzip
(package
(name "camlzip")
- (version "1.0.6")
+ (version "1.11")
(source (origin
- (method url-fetch)
- (uri (ocaml-forge-uri name version 1616))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xavierleroy/camlzip")
+ (commit (string-append
+ "rel"
+ (string-join (string-split version #\.) "")))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0m6gyjw46w3qnhxfsyqyag42znl5lwargks7w7rfchr9jzwpff68"))))
+ "16jnn3czxnvyjngnz167x5kw097k7izdqvkix8qvgvhdmgvqm89b"))))
(build-system ocaml-build-system)
(inputs
`(("zlib" ,zlib)))
(arguments
`(#:phases
(modify-phases %standard-phases
- (delete 'configure)
- (add-after 'install 'install-camlzip
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/lib/ocaml/site-lib/camlzip")))
- (mkdir-p dir)
- (call-with-output-file (string-append dir "/META")
- (lambda (port)
- (format port "version=\"1.06\"\n")
- (format port "requires=\"unix\"\n")
- (format port "archive(byte)=\"zip.cma\"\n")
- (format port "archive(native)=\"zip.cmxa\"\n")
- (format port "archive(native,plugin)=\"zip.cmxs\"\n")
- (format port "directory=\"../zip\"\n")))))))
+ (delete 'configure))
#:install-target "install-findlib"
#:make-flags
(list "all" "allopt"