summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre-Moana Levesque <pierre.moana.levesque@gmail.com>2019-07-31 13:18:08 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-24 08:14:13 +0200
commit8e8855f9aa0521ade0741896b2285d9ddf493fed (patch)
tree538f861862c35d8116a3baea3314c024672c91aa /gnu
parenteff633257cc191d33b93cb1ada6ef34daa969c00 (diff)
downloadguix-patches-8e8855f9aa0521ade0741896b2285d9ddf493fed.tar
guix-patches-8e8855f9aa0521ade0741896b2285d9ddf493fed.tar.gz
gnu: nghttp2: Fix cross-compilation.
* gnu/packages/web.scm (nghttp2)[arguments]: In set-timezone-directory phase, search in both inputs and native-inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b415a149b7..d23f6cb400 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.lonestar.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6444,9 +6445,10 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
(assoc-ref outputs "lib")))
#t))
(add-before 'check 'set-timezone-directory
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo"))
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (setenv "TZDIR" (string-append
+ (assoc-ref (or native-inputs inputs) "tzdata")
+ "/share/zoneinfo"))
#t)))))
(home-page "https://nghttp2.org/")
(synopsis "HTTP/2 protocol client, proxy, server, and library")