summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-01 16:29:31 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-01 22:21:00 +0100
commit66b89ee28e1b15ff962b68e91fcd84562102fc2f (patch)
treec771c7a86228909ed07fb67b3fce3f4175d2daa6 /gnu
parent57c734a628091f45cea205acfceba34d2dda3ef9 (diff)
downloadguix-patches-66b89ee28e1b15ff962b68e91fcd84562102fc2f.tar
guix-patches-66b89ee28e1b15ff962b68e91fcd84562102fc2f.tar.gz
gnu: python-stem: Update phase style.
* gnu/packages/python.scm (python-stem)[arguments]: Substitute INVOKE for SYSTEM* and end phase with #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 69101c78b9..0b7ff440f0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9366,7 +9366,8 @@ etc.")
(modify-phases %standard-phases
(replace 'check
(lambda _
- (zero? (system* "./run_tests.py" "--unit")))))))
+ (invoke "./run_tests.py" "--unit")
+ #t)))))
(native-inputs
`(("python-mock" ,python-mock)
("python-pep8" ,python-pep8)