summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-19 18:41:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-01 21:12:59 +0100
commit643817e44534f58b28bb41bf75ebf7ad240e49f4 (patch)
tree076e0083724f6347832f62c829af22ec84bb75b3 /gnu
parent1debc5b9d281660a73b6ed777546213b0d9b7b32 (diff)
downloadguix-patches-643817e44534f58b28bb41bf75ebf7ad240e49f4.tar
guix-patches-643817e44534f58b28bb41bf75ebf7ad240e49f4.tar.gz
gnu: Add patchmatrix.
* gnu/packages/music.scm (patchmatrix): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 63b82900c0..65dfa92896 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3726,6 +3726,34 @@ notation and includes basic support for digital audio.")
(home-page "http://www.rosegardenmusic.com/")
(license license:gpl2)))
+(define-public patchmatrix
+ (package
+ (name "patchmatrix")
+ (version "0.12.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OpenMusicKontrollers/patchmatrix.git")
+ (commit version)))
+ (file-name (string-append "patchmatrix-" version "-checkout"))
+ (sha256
+ (base32
+ "19ivp7h5vq6r1qhmycjxzvrgg7fc4a3v5vb3n4c7afs4z3pj53zi"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; no test target
+ (inputs
+ `(("jack" ,jack-1)
+ ("lv2" ,lv2)
+ ("mesa" ,mesa)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://github.com/OpenMusicKontrollers/patchmatrix")
+ (synopsis "Simple JACK patch bay")
+ (description "PatchMatrix is a patch bay for the JACK audio connection
+kit. It provides a patch bay in flow matrix style for audio, MIDI, CV, and
+OSC connections.")
+ (license license:artistic2.0)))
+
(define-public sorcer
(package
(name "sorcer")