summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-06 21:42:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-03 23:00:54 +0100
commitfc9082e4e571c165a010806948275096a902a914 (patch)
tree06ae735ebe4efde05e060aec6d80b0ab69096e8d /gnu
parent2eb523a3894e01b83397ff7426b3df0aee3c8a0e (diff)
downloadguix-patches-fc9082e4e571c165a010806948275096a902a914.tar
guix-patches-fc9082e4e571c165a010806948275096a902a914.tar.gz
gnu: Add rust-lexical-6.
* gnu/packages/crates-io.scm (rust-lexical-6): New variable. (rust-lexical-5): Inherit from above.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 26 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index df08cd80b3..19f35a2e45 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25508,8 +25508,33 @@ sending emails from Rust applications.")
"This crate provides efficient formatting of integers to strings.")
(license (list license:expat license:asl2.0))))
+(define-public rust-lexical-6
+ (package
+ (name "rust-lexical")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "lexical" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1y8v2s8g2hjinwf5hbm1ncbazw9q4qbp111q2mwacq6hi0grhkn3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-lexical-core" ,rust-lexical-core-0.8))))
+ (home-page "https://github.com/Alexhuszagh/rust-lexical")
+ (synopsis "Lexical, to- and from-string conversion routines")
+ (description
+ "Lexical is high-performance numeric conversion routines for use in
+a no_std environment. This does not depend on any standard library features,
+nor a system allocator.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-lexical-5
(package
+ (inherit rust-lexical-6)
(name "rust-lexical")
(version "5.2.2")
(source
@@ -25519,7 +25544,6 @@ sending emails from Rust applications.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1r8lsi523h53kbb99xgv31jabwhcp4rzqd4hfazfhcjffh5aj17l"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
@@ -25528,13 +25552,7 @@ sending emails from Rust applications.")
("rust-rand" ,rust-rand-0.4)
("rust-serde" ,rust-serde-1)
("rust-serde-derive" ,rust-serde-derive-1)
- ("rust-toml" ,rust-toml-0.5))))
- (home-page "https://github.com/Alexhuszagh/rust-lexical")
- (synopsis "Lexical, to- and from-string conversion routines")
- (description
- "Lexical provides routines to convert numbers to and from decimal
-strings.")
- (license (list license:expat license:asl2.0))))
+ ("rust-toml" ,rust-toml-0.5))))))
(define-public rust-libc-0.2
(package