summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:38 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:16 -0700
commit4562c8c894b16dcea4875c4dea19565de9a4c34c (patch)
tree672015c4da212b5a329cde947e7bf258f4ddef7c /gnu
parente329bacb850130d49a1973cdcc6086e7b4257809 (diff)
downloadguix-patches-4562c8c894b16dcea4875c4dea19565de9a4c34c.tar
guix-patches-4562c8c894b16dcea4875c4dea19565de9a4c34c.tar.gz
gnu: Add ghc-contravariant-extras.
* gnu/packages/haskell.scm (ghc-contravariant-extras): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 31edf24485..23c2d31326 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9491,4 +9491,27 @@ generating functions similar to those in @code{Data.List} for tuples of
statically known size.")
(license license:bsd-3)))
+(define-public ghc-contravariant-extras
+ (package
+ (name "ghc-contravariant-extras")
+ (version "0.3.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "contravariant-extras-" version "/"
+ "contravariant-extras-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1mbrgjybdx8fjdck4ldwi8955w4qnmm0ql56zix7dyn0s7s9spgk"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-tuple-th" ,ghc-tuple-th)
+ ("ghc-contravariant" ,ghc-contravariant)
+ ("ghc-base-prelude",ghc-base-prelude)))
+ (home-page "https://github.com/nikita-volkov/contravariant-extras")
+ (synopsis "Extras for the @code{ghc-contravariant} Haskell package")
+ (description "This Haskell package provides extras for the
+@code{ghc-contravariant} package.")
+ (license license:expat)))
+
;;; haskell.scm ends here