summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-11-04 21:34:11 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-06 10:43:28 +0100
commit36d1f71440162388e7901234875298bf947c3679 (patch)
tree3662d6f7386d86f788e3b7d160fcb5b100367315 /gnu
parentd82fd7c2dd542693988f61fb15c020e3209ac7ec (diff)
downloadguix-patches-36d1f71440162388e7901234875298bf947c3679.tar
guix-patches-36d1f71440162388e7901234875298bf947c3679.tar.gz
gnu: Add emacs-ntlm.
* gnu/packages/emacs-xyz.scm (emacs-ntlm): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d3901af675..feca4feb31 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019, 2020, 2021 Joseph LaFreniere <joseph@lafreniere.xyz>
+;;; Copyright © 2019 Todor Kondić <tk.code@protonmail.com>15669
;;; Copyright © 2019 Amar Singh <nly@disroot.org>
;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
@@ -25658,6 +25659,24 @@ provided. Those alternative commands are and bound by default to their
corresponding Evil keys.")
(license license:expat))))
+(define-public emacs-ntlm
+ (package
+ (name "emacs-ntlm")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/ntlm-" version ".el"))
+ (sha256
+ (base32 "01d0bcmh8a36qf871w6bc05kjk9bmnh843m9869xw06zyvqwg9mv"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/ntlm.html")
+ (synopsis "NTLM (NT LanManager) authentication support")
+ (description
+ "This library is a direct translation of the Samba release 2.2.0
+implementation of Windows NT and LanManager compatible password encryption.")
+ (license license:gpl3+)))
+
(define-public emacs-evil-traces
(let ((commit "1931e3ea2c64b4aec393a9c25063c330deff55e3")
(revision "2"))