summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-10-06 16:52:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-11-03 23:00:45 +0100
commit1ab8cdedef2ffb39039279d9effd608df931417b (patch)
treec6177ea27f15c2aaafec95d637bcd70647d5535e /gnu
parent4dca103962694ee5141c583fbd52e26cc2b3f275 (diff)
downloadguix-patches-1ab8cdedef2ffb39039279d9effd608df931417b.tar
guix-patches-1ab8cdedef2ffb39039279d9effd608df931417b.tar.gz
gnu: Add rust-hash-hasher-2.
* gnu/packages/crates-io.scm (rust-hash-hasher-2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index aea871e1d8..40896056a4 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21146,6 +21146,26 @@ the template engine that renders the official Rust website")
"This package provides a Rust implementation of VG handle graph.")
(license license:expat)))
+(define-public rust-hash-hasher-2
+ (package
+ (name "rust-hash-hasher")
+ (version "2.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hash_hasher" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "034cd4m3znwff3cd1i54c40944y999jz086d70rwpl0jfl01swkl"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/Fraser999/Hash-Hasher.git")
+ (synopsis "Hasher designed to work with already-hashed or hash-like data")
+ (description
+ "This package provides a hasher which is designed to work with
+already-hashed or hash-like data.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-hash32-0.1
(package
(name "rust-hash32")