summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-03 14:54:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-03 14:55:38 +0100
commitb8d6e77476f9515e53cd00c007d6f4c565a3e99d (patch)
treee162a3465537d854234649c69c7678158c26ffe0 /gnu
parentd0aa14a43dec5dbfcf950d77e07725de46fa6139 (diff)
downloadguix-patches-b8d6e77476f9515e53cd00c007d6f4c565a3e99d.tar
guix-patches-b8d6e77476f9515e53cd00c007d6f4c565a3e99d.tar.gz
gnu: python-ont-fast5-api: Update to 4.0.0.
* gnu/packages/bioinformatics.scm (python-ont-fast5-api): Update to 4.0.0. [source]: Remove bundled plugin binaries. [arguments]: Install plugin from inputs. [inputs]: Add vbz-compression. [propagated-inputs]: Remove python-six; add python-packaging.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index d180db012e..cb4f1b345a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -13896,7 +13896,7 @@ effective when applied to the signal dataset.")
(define-public python-ont-fast5-api
(package
(name "python-ont-fast5-api")
- (version "1.4.4")
+ (version "4.0.0")
(source
(origin
(method git-fetch)
@@ -13906,12 +13906,27 @@ effective when applied to the signal dataset.")
(file-name (git-file-name name version))
(sha256
(base32
- "03cbq4zbbwhll8ml2m9k8sa31mirsvcbjkrq1yna0kkzz9fad5fm"))))
+ "01hj4751j424lzic2sc4bz1f8w7i7fpkjpy3rgghdyl5lyfyb4s4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(delete-file-recursively "ont_fast5_api/vbz_plugin"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'copy-plugin
+ (lambda* (#:key inputs #:allow-other-keys)
+ (mkdir-p "ont_fast5_api/vbz_plugin/")
+ (install-file (string-append
+ (assoc-ref inputs "vbz-compression")
+ "/hdf5/lib/plugin/libvbz_hdf_plugin.so")
+ "ont_fast5_api/vbz_plugin/"))))))
+ (inputs
+ `(("vbz-compression" ,vbz-compression)))
(propagated-inputs
`(("python-numpy" ,python-numpy)
- ("python-six" ,python-six)
("python-h5py" ,python-h5py)
+ ("python-packaging" ,python-packaging)
("python-progressbar33" ,python-progressbar33)))
(home-page "https://github.com/nanoporetech/ont_fast5_api")
(synopsis "Interface to HDF5 files of the Oxford Nanopore fast5 file format")