summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-25 16:47:20 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-25 16:47:20 +0200
commit9eed6f9b88ed589d7531e2d5cecc73fd095db523 (patch)
treea2dbe6c1ad693a7822cbc9bb05dcfe7673cebc9c /gnu
parentf29f066439d8a030e53f2fb3ac269be00fb46e20 (diff)
downloadguix-patches-9eed6f9b88ed589d7531e2d5cecc73fd095db523.tar
guix-patches-9eed6f9b88ed589d7531e2d5cecc73fd095db523.tar.gz
gnu: pius: Use the right `gpg' binary.
* gnu/packages/gnupg.scm (pius): Add GnuPG as an input. Patch the installed binaries to refer to the right GnuPG executable. Fix synopsis.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnupg.scm20
1 files changed, 12 insertions, 8 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index b3b6dc92ab..604ebc2941 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -191,7 +191,8 @@ S/MIME.")
"1g1jly3wl4ks6h8ydkygyl2c4i7v3z91rg42005m6vm70y1d8b3d"))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
- ("python" ,python)))
+ ("python" ,python)
+ ("gpg" ,gnupg)))
(arguments
`(#:tests? #f
#:phases
@@ -203,16 +204,19 @@ S/MIME.")
(lambda* (#:key #:allow-other-keys) #t)
(alist-replace
'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (gpg (string-append (assoc-ref inputs "gpg")
+ "/bin/gpg2")))
(mkdir out)
(mkdir (string-append out "/bin"))
- (for-each
- (lambda (filename)
- (copy-file filename (string-append out "/bin/" filename)))
- '("pius" "pius-keyring-mgr" "pius-party-worksheet"))))
+ (for-each (lambda (file)
+ (substitute* file
+ (("/usr/bin/gpg") gpg))
+ (copy-file file (string-append out "/bin/" file)))
+ '("pius" "pius-keyring-mgr" "pius-party-worksheet"))))
%standard-phases)))))
- (synopsis "programs to simplify gnupg key signing")
+ (synopsis "Programs to simplify GnuPG key signing")
(description
"Pius (PGP Individual UID Signer) helps attendees of PGP keysigning
parties. It is the main utility and makes it possible to quickly and easily