summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-14 16:47:59 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 13:02:54 -0400
commitb87dbf213bda508a580a92f111d73385c4bad07d (patch)
tree66332b2eae6d7517021976f8c32d2e5b5f3dea52 /gnu
parentf1f6ede7f802f3b9113192a5947ead105af6e06f (diff)
downloadguix-patches-b87dbf213bda508a580a92f111d73385c4bad07d.tar
guix-patches-b87dbf213bda508a580a92f111d73385c4bad07d.tar.gz
gnu: Add python-robotframework-seleniumscreenshots.
* gnu/packages/python-xyz.scm (python-robotframework-seleniumscreenshots): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d35afa5bf9..6fd6749309 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4577,6 +4577,33 @@ library APIs.")
that utilizes the Selenium tool internally.")
(license license:asl2.0)))
+(define-public python-robotframework-seleniumscreenshots
+ (package
+ (name "python-robotframework-seleniumscreenshots")
+ (version "0.9.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "robotframework-seleniumscreenshots" version))
+ (sha256
+ (base32 "05qv323hvjmy62h33ryrjaa9k1hyvp8hq5qnj8j1x3ap2ci3q3s0"))))
+ (build-system python-build-system)
+ (arguments
+ ;; XXX: The tests require a relatively complicated setup configured in
+ ;; their CI with Nix (!).
+ `(#:tests? #f))
+ (propagated-inputs
+ `(("python-robotframework" ,python-robotframework)
+ ("python-robotframework-seleniumlibrary"
+ ,python-robotframework-seleniumlibrary)))
+ (home-page "https://github.com/MarketSquare/robotframework-seleniumscreenshots")
+ (synopsis "Robot Framework library for annotating and cropping screenshots")
+ (description "The SeleniumScreenshots library for Robot Framework provides
+keywords for annotating and cropping screenshots taken with SeleniumLibrary.
+It is useful for scripting automatically updated screenshots for documentation
+or for visual regression testing purposes.")
+ (license license:bsd-3)))
+
(define-public python-rstr
(package
(name "python-rstr")