summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 14:02:44 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:59 +0200
commit2a0fcc31f723e20fd81eb3c6263c1bdad56f797f (patch)
tree31c6ced16ad87a66d93b16c2ed6f51bde8566112 /gnu
parentb3c1c37d743f55c716727a3efe9067654b9687f5 (diff)
downloadguix-patches-2a0fcc31f723e20fd81eb3c6263c1bdad56f797f.tar
guix-patches-2a0fcc31f723e20fd81eb3c6263c1bdad56f797f.tar.gz
gnu: Add aws-c-mqtt.
* gnu/packages/c.scm (aws-c-mqtt): New variable. * gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/c.scm28
-rw-r--r--gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch13
3 files changed, 42 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4226618768..508d5ac86c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -876,6 +876,7 @@ dist_patch_DATA = \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-disable-networking-tests.patch\
+ %D%/packages/patches/aws-c-mqtt-cmake-prefix.patch \
%D%/packages/patches/aws-c-io-cmake-prefix.patch \
%D%/packages/patches/aws-c-io-disable-networking-tests.patch \
%D%/packages/patches/aws-c-s3-cmake-prefix.patch \
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index cd31c97285..c6399280f6 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -834,3 +834,31 @@ authentication.")
Service (S3) protocol for object storage.")
(home-page "https://github.com/awslabs/aws-c-s3")
(license license:asl2.0)))
+
+(define-public aws-c-mqtt
+ (package
+ (name "aws-c-mqtt")
+ (version "0.7.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qgblakp9n281z5w1kmmy9sjiz6s44kg487l76w7p43p1dp7s401"))
+ (patches (search-patches "aws-c-mqtt-cmake-prefix.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-http" ,aws-c-http)
+ ("aws-c-io" ,aws-c-io)))
+ (synopsis "Amazon Web Services MQTT library")
+ (description
+ "This library provides a C99 implementation of the Message Queuing
+Telemetry Transport (MQTT) publish-subscribe messaging protocol.")
+ (home-page "https://github.com/awslabs/aws-c-mqtt")
+ (license license:asl2.0)))
diff --git a/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch b/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch
new file mode 100644
index 0000000000..987024b57c
--- /dev/null
+++ b/gnu/packages/patches/aws-c-mqtt-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,10 @@ if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()