summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-14 15:17:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 13:02:53 -0400
commit1fdad09d1c48cfc02eabd056d96b52c7fef465cb (patch)
treef6026d5df6b718dcc3aa9b13e4889cb5648b37b0 /gnu
parent2cc617c18156b582d9d0e4d6959d257e552f0eae (diff)
downloadguix-patches-1fdad09d1c48cfc02eabd056d96b52c7fef465cb.tar
guix-patches-1fdad09d1c48cfc02eabd056d96b52c7fef465cb.tar.gz
gnu: python-robotframework-sshlibrary: Update to 3.7.0 and honor TESTS?.
* gnu/packages/python-xyz.scm (python-robotframework-sshlibrary): Update to 3.7.0. [phases]: Delete trailing #t. {check}: Honor TESTS?.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eca4bf2537..2120414b7b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4458,7 +4458,7 @@ utility, a static analysis tool (linter) for Robot Framework source files.")
(define-public python-robotframework-sshlibrary
(package
(name "python-robotframework-sshlibrary")
- (version "3.3.0")
+ (version "3.7.0")
;; There are no tests in the PyPI archive.
(source
(origin
@@ -4469,7 +4469,7 @@ utility, a static analysis tool (linter) for Robot Framework source files.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mk6dz2jqqndbx4yji09012q6rmadnqdywi7czvj62b0s07dr3r2"))))
+ "09ak22rh9qa9wlpvhkliyybcp4xafjhxsps28wz0pf0030771xav"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -4483,14 +4483,14 @@ utility, a static analysis tool (linter) for Robot Framework source files.")
(invoke "invoke" "kw-docs" "project-docs")
(mkdir-p doc)
(for-each delete-file (find-files "docs" "\\.rst"))
- (copy-recursively "docs" doc)
- #t)))
+ (copy-recursively "docs" doc))))
(replace 'check
- (lambda _
- ;; Some tests require an SSH server; we remove them.
- (delete-file "utest/test_client_api.py")
- (delete-file "utest/test_scp.py")
- (invoke "python" "utest/run.py"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Some tests require an SSH server; we remove them.
+ (delete-file "utest/test_client_api.py")
+ (delete-file "utest/test_scp.py")
+ (invoke "python" "utest/run.py")))))))
(propagated-inputs
`(("python-robotframework" ,python-robotframework)
("python-paramiko" ,python-paramiko)