summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:00:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:26 +0300
commit6496b31a66b5665c55ec11a14e73f278d34f8a35 (patch)
tree068db83c495112240aa655fa02125fcba0c9c5cf /gnu
parent130c13c877db9252a9c578a66f65483a32fecd64 (diff)
downloadguix-patches-6496b31a66b5665c55ec11a14e73f278d34f8a35.tar
guix-patches-6496b31a66b5665c55ec11a14e73f278d34f8a35.tar.gz
gnu: Add julia-static.
* gnu/packages/julia-xyz.scm (julia-static): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index aea117395c..21d2f4de2e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1620,6 +1620,30 @@ default are documented to have non-stable streams (which for example enables
some performance improvements).")
(license license:expat)))
+(define-public julia-static
+ (package
+ (name "julia-static")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SciML/Static.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01rbiysrkaca03gh55rc5zykkp63bhzaqgrxxj88lnisrbzmf0d2"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-ifelse" ,julia-ifelse)))
+ (native-inputs
+ `(("julia-aqua" ,julia-aqua)))
+ (home-page "https://github.com/SciML/Static.jl")
+ (synopsis "Static types useful for dispatch and generated functions")
+ (description "Static.jl defines a limited set of statically parameterized
+types and a common interface that is shared between them.")
+ (license license:expat)))
+
(define-public julia-staticarrays
(package
(name "julia-staticarrays")