summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-19 16:37:05 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-19 16:37:05 +0100
commitc72aed6d8c000efcc4cd3a912b13773e9ed46453 (patch)
treef7fda7fa9fb8a50898a3417ba3364894f65f01b4 /gnu
parentd35c5e29b6cae013aa0f4e8b075670010b9c9ce1 (diff)
downloadguix-patches-c72aed6d8c000efcc4cd3a912b13773e9ed46453.tar
guix-patches-c72aed6d8c000efcc4cd3a912b13773e9ed46453.tar.gz
gnu: emms: Let the build system install emms-print-metadata.1.
Reported by effa`` on #guix. * gnu/packages/emacs.scm (emms)[arguments] <pre-install>: Remove 'copy-file' invocation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9ccf34c362..f4d7ac9748 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Alex Kost <alezost@gmail.com>
;;;
@@ -482,13 +482,12 @@ operations.")
(alist-cons-before
'install 'pre-install
(lambda* (#:key outputs #:allow-other-keys)
- ;; The 'install' rule expects 'emms-print-metadata.1' to
- ;; be already installed.
+ ;; The 'install' rule expects the target directory to
+ ;; exist.
(let* ((out (assoc-ref outputs "out"))
(man1 (string-append out "/share/man/man1")))
(mkdir-p man1)
- (copy-file "emms-print-metadata.1"
- (string-append man1 "/emms-print-metadata.1"))))
+ #t))
(alist-cons-after
'install 'post-install
(lambda* (#:key outputs #:allow-other-keys)
@@ -505,8 +504,7 @@ operations.")
#:tests? #f))
(native-inputs `(("emacs" ,emacs) ;for (guix build emacs-utils)
("texinfo" ,texinfo)))
- (inputs `(;("perl" ,perl) ;for 'emms-print-metadata.pl'
- ("alsa-utils" ,alsa-utils)
+ (inputs `(("alsa-utils" ,alsa-utils)
("vorbis-tools" ,vorbis-tools)
("mpg321" ,mpg321)
("taglib" ,taglib)