summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-11-19 16:07:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-11-19 16:10:52 +0100
commitbc8bf605fcef7d9e8a7732caa0fd54604304635b (patch)
treee28147f8f4f8cf522f49ec2d99e6933f5fcf7642 /gnu
parent80e6f37e30e1b46c1cc5ba7e9b429ae5483f59da (diff)
downloadguix-patches-bc8bf605fcef7d9e8a7732caa0fd54604304635b.tar
guix-patches-bc8bf605fcef7d9e8a7732caa0fd54604304635b.tar.gz
gnu: jack-2: Fix jack_control script.
* gnu/packages/audio.scm (jack-2)[inputs]: Add python2-dbus. [arguments]: Use python-2 and add build phase to wrap jack_control Python script.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 4a86a8d543..91b70ce17b 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -684,7 +684,8 @@ synchronous execution of all clients, and low latency operation.")
"03b0iiyk3ng3vh5s8gaqwn565vik7910p56mlbk512bw3dhbdwc8"))))
(build-system waf-build-system)
(arguments
- `(#:tests? #f ; no check target
+ `(#:python ,python-2
+ #:tests? #f ; no check target
#:configure-flags '("--dbus"
"--alsa")
#:phases
@@ -697,13 +698,22 @@ synchronous execution of all clients, and low latency operation.")
((".*CFLAGS.*-Wall.*" m)
(string-append m
" conf.env.append_unique('LINKFLAGS',"
- "'-Wl,-rpath=" %output "/lib')\n"))))))))
+ "'-Wl,-rpath=" %output "/lib')\n")))))
+ (add-after 'install 'wrap-python-scripts
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Make sure 'jack_control' runs with the correct PYTHONPATH.
+ (let* ((out (assoc-ref outputs "out"))
+ (path (getenv "PYTHONPATH")))
+ (wrap-program (string-append out "/bin/jack_control")
+ `("PYTHONPATH" ":" prefix (,path))))
+ #t)))))
(inputs
`(("alsa-lib" ,alsa-lib)
("dbus" ,dbus)
("expat" ,expat)
("libsamplerate" ,libsamplerate)
("opus" ,opus)
+ ("python2-dbus" ,python2-dbus)
("readline" ,readline)))
(native-inputs
`(("pkg-config" ,pkg-config)))