summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-09-01 17:46:49 +0200
committerAndreas Enge <andreas@enge.fr>2013-09-01 17:46:49 +0200
commit77c7f8f41b558bab13690c843068af8ba996e5bf (patch)
tree1b94edffdf1d06f3f78d8e1dc26b6f9a46e97270 /gnu
parent93d44bd8decac576a5cd0bcd8356e6fcf6083ee5 (diff)
downloadguix-patches-77c7f8f41b558bab13690c843068af8ba996e5bf.tar
guix-patches-77c7f8f41b558bab13690c843068af8ba996e5bf.tar.gz
gnu: python: Temporarily make python 2 the default.
* gnu/packages/python.scm (python-2): Rename this to... * gnu/packages/python.scm (python): ...this, rename this to... * gnu/packages/python.scm (python-3): ...this. Reverts to version 2 as the default input for packages requiring Python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0a3977aabb..493068adde 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -31,7 +31,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system python))
-(define-public python-2
+(define-public python
(package
(name "python")
(version "2.7.5")
@@ -151,8 +151,8 @@ packages; exception-based error handling; and very high level dynamic
data types.")
(license psfl)))
-(define-public python
- (package (inherit python-2)
+(define-public python-3
+ (package (inherit python)
(version "3.3.2")
(source
(origin