summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazev@posteo.org>2022-01-21 23:04:42 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-22 13:09:24 +0100
commit21a93bf85f5bccc4ba03e5b5650eb05319320b4a (patch)
tree68383be1f6c608c98e7156c91f5bd55a5193a323 /gnu
parentb3a14b57b99f768210a8a939925545b980fbad3c (diff)
downloadguix-patches-21a93bf85f5bccc4ba03e5b5650eb05319320b4a.tar
guix-patches-21a93bf85f5bccc4ba03e5b5650eb05319320b4a.tar.gz
gnu: Add rust-chacha20-0.8.
* gnu/packages/crates-io.scm (rust-chacha20-0.8): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 661eba79f1..76d4188a45 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9278,6 +9278,38 @@ chain, the first matching branch is the item that gets emitted.")
(("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))))))
+(define-public rust-chacha20-0.8
+ (package
+ (name "rust-chacha20")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "chacha20" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "14cgpnnpqsn5hmqkgrj4yaqdsvy56hkgcw5s2gqsxwhc7m1jmdq1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-cipher" ,rust-cipher-0.3)
+ ("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-rand-core" ,rust-rand-core-0.6)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-cipher" ,rust-cipher-0.3)
+ ("rust-hex-literal" ,rust-hex-literal-0.2))))
+ (home-page "https://github.com/RustCrypto/stream-ciphers")
+ (synopsis "ChaCha20 stream cipher implemented in pure Rust")
+ (description
+ "The ChaCha20 stream cipher (RFC 8439) implemented in pure Rust using traits
+from the RustCrypto @code{cipher} crate, with optional architecture-specific
+hardware acceleration (AVX2, SSE2). Additionally provides the ChaCha8, ChaCha12,
+XChaCha20, XChaCha12 and XChaCha8 stream ciphers, and also optional
+@code{rand_core-compatible} RNGs based on those ciphers.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-chalk-derive-0.75
(package
(name "rust-chalk-derive")