summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-06-05 15:35:42 +0200
committerMarius Bakke <marius@gnu.org>2021-06-13 01:00:47 +0200
commita6c292a6f123acc86429722619ccb51ca54f844f (patch)
treecafa380132b6952f947084975e7995515ecd8840 /gnu
parent557084a0c9f2e1b91f7e7da68d3f9540c044bffb (diff)
downloadguix-patches-a6c292a6f123acc86429722619ccb51ca54f844f.tar
guix-patches-a6c292a6f123acc86429722619ccb51ca54f844f.tar.gz
gnu: expat: Install the static library.
* gnu/packages/xml.scm (expat)[outputs]: New field. [arguments]: Remove #:configure-flags. Add #:phases. * gnu/packages/commencement.scm (expat-sans-tests)[outputs]: New field. [arguments]: Add #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm2
-rw-r--r--gnu/packages/xml.scm14
2 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index bc2e82ffab..d44d1dd3ca 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3053,6 +3053,7 @@ memoized as a function of '%current-system'."
(package
(inherit expat)
(inputs (%boot0-inputs))
+ (outputs '("out"))
(arguments
;; XXX: Linking 'runtestscpp' fails with things like:
;;
@@ -3067,6 +3068,7 @@ memoized as a function of '%current-system'."
;; Since we're not passing the right -Wl,-rpath flags, build the
;; static library to avoid RUNPATH validation failure.
`(cons "--disable-shared" ,flags))
+ ((#:phases phases) '%standard-phases)
((#:tests? _ #f) #f))))))
(define python-boot0
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 78daa6c10c..a57a44f727 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -135,7 +135,19 @@ the entire document.")
"0spvyb9d3hijs4ys3x64cfmilsynl8kv6clfahv8d4lvp86js0yg")))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-static")))
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'install 'move-static-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (static (assoc-ref outputs "static")))
+ (mkdir-p (string-append static "/lib"))
+ (link (string-append out "/lib/libexpat.a")
+ (string-append static "/lib/libexpat.a"))
+ (delete-file (string-append out "/lib/libexpat.a"))
+ (substitute* (string-append out "/lib/libexpat.la")
+ (("old_library=.*")
+ "old_library=''"))))))))
+ (outputs '("out" "static"))
(home-page "https://libexpat.github.io/")
(synopsis "Stream-oriented XML parser library written in C")
(description