summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:19:14 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:40 +0200
commit574edcc006322f0ecc084820cb93234fa66e802a (patch)
tree02667b7c05e9fda5feffcbedc97de12608c4b0a3 /gnu
parent02fbb5c3041b37b2a833ea632d4e76fdcb1900cc (diff)
downloadguix-patches-574edcc006322f0ecc084820cb93234fa66e802a.tar
guix-patches-574edcc006322f0ecc084820cb93234fa66e802a.tar.gz
gnu: sbcl-flexi-streams: Don't use unstable tarball.
* gnu/packages/lisp.scm (sbcl-flexi-streams)[source]: Use GIT-FETCH and GIT-FILE-NAME. [arguments]: Add ‘make-git-checkout-writable’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 1cb62ae74b..824027c5c5 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -818,14 +818,21 @@ logical continuation of Stefil. It focuses on interactive debugging.")
(version "1.0.16")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/edicl/flexi-streams/archive/v"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/edicl/flexi-streams.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "flexi-streams" version))
(sha256
- (base32 "1fb0jrwxr5c3i2lhy7kn30m1n0vggfzwjm1dacx6y5wf9wfsbamw"))
- (file-name (string-append "flexi-streams-" version ".tar.gz"))))
+ (base32 "0gvykjlmja060zqq6nn6aqxlshh6r6ijahmmgf20q0d839rwpgxc"))))
(build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t)))))
(inputs `(("trivial-gray-streams" ,sbcl-trivial-gray-streams)))
(synopsis "Implementation of virtual bivalent streams for Common Lisp")
(description "Flexi-streams is an implementation of \"virtual\" bivalent