summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-08 10:20:04 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-08 11:04:43 +0200
commit72d65449ed9fcd74dd380c4443e2e7e73fe9660b (patch)
tree7f9b55e488d75bd5199917b8f6f0f813d6e21660 /gnu
parenta3c5f056a8c007ca1e19d48a55e8d9856c778278 (diff)
downloadguix-patches-72d65449ed9fcd74dd380c4443e2e7e73fe9660b.tar
guix-patches-72d65449ed9fcd74dd380c4443e2e7e73fe9660b.tar.gz
gnu: Add rust-watchexec-1.
* gnu/packages/crates-io.scm (rust-watchexec-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7849f79cf2..8899080844 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -50045,6 +50045,39 @@ attribute that is not in the shared backend crate.")
WebAssembly binary files.")
(license license:asl2.0)))
+(define-public rust-watchexec-1
+ (package
+ (name "rust-watchexec")
+ (version "1.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "watchexec" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1v52fi5fvjr7h5npyjkwnfc7801qrl4ayzgq4k03ylxr4lkbvhsb"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-clearscreen" ,rust-clearscreen-1)
+ ("rust-derive-builder" ,rust-derive-builder-0.10)
+ ("rust-glob" ,rust-glob-0.3)
+ ("rust-globset" ,rust-globset-0.4)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-nix" ,rust-nix-0.20)
+ ("rust-notify" ,rust-notify-4)
+ ("rust-walkdir" ,rust-walkdir-2)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/watchexec/watchexec")
+ (synopsis
+ "Library to execute commands in response to file modifications")
+ (description
+ "This crate is a library to execute commands in response to file
+modifications.")
+ (license license:asl2.0)))
+
(define-public rust-web-sys-0.3
(package
(name "rust-web-sys")