summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2021-08-30 12:17:11 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-09-09 20:26:50 +0300
commit833a78b16c5089cb6d3289a965f97b7c425627ab (patch)
tree3cb846ca2aa5e71d6c0ec45e5bdfec2b5e909b00 /gnu
parent7fcc64253c2c48fee96f7925453161eb2b3a709e (diff)
downloadguix-patches-833a78b16c5089cb6d3289a965f97b7c425627ab.tar
guix-patches-833a78b16c5089cb6d3289a965f97b7c425627ab.tar.gz
home-services: Add utils module.
* gnu/home-services/utils.scm (maybe-object->string object->snake-case-string) (object->snake-case-string): New variables. * gnu/local.mk (GNU_SYSTEM_MODULES): Add home-services/utils.scm. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/home-services/shells.scm1
-rw-r--r--gnu/home-services/utils.scm77
-rw-r--r--gnu/local.mk1
3 files changed, 79 insertions, 0 deletions
diff --git a/gnu/home-services/shells.scm b/gnu/home-services/shells.scm
index b8065d28d2..ecb02098f7 100644
--- a/gnu/home-services/shells.scm
+++ b/gnu/home-services/shells.scm
@@ -20,6 +20,7 @@
(define-module (gnu home-services shells)
#:use-module (gnu services configuration)
#:use-module (gnu home-services configuration)
+ #:use-module (gnu home-services utils)
#:use-module (gnu home-services)
#:use-module (gnu packages shells)
#:use-module (gnu packages bash)
diff --git a/gnu/home-services/utils.scm b/gnu/home-services/utils.scm
new file mode 100644
index 0000000000..3e490a0515
--- /dev/null
+++ b/gnu/home-services/utils.scm
@@ -0,0 +1,77 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu home-services utils)
+ #:use-module (ice-9 string-fun)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+
+ #:export (maybe-object->string
+ object->snake-case-string
+ object->camel-case-string))
+
+(define (maybe-object->string object)
+ "Like @code{object->string} but don't do anyting if OBJECT already is
+a string."
+ (if (string? object)
+ object
+ (object->string object)))
+
+;; Snake case: <https://en.wikipedia.org/wiki/Snake_case>
+(define* (object->snake-case-string object #:optional (style 'lower))
+ "Convert the object OBJECT to the equivalent string in ``snake
+case''. STYLE can be three `@code{lower}', `@code{upper}', or
+`@code{capitalize}', defaults to `@code{lower}'.
+
+@example
+(object->snake-case-string 'variable-name 'upper)
+@result{} \"VARIABLE_NAME\" @end example"
+ (if (not (member style '(lower upper capitalize)))
+ (error 'invalid-style (format #f "~a is not a valid style" style))
+ (let ((stringified (maybe-object->string object)))
+ (string-replace-substring
+ (cond
+ ((equal? style 'lower) stringified)
+ ((equal? style 'upper) (string-upcase stringified))
+ (else (string-capitalize stringified)))
+ "-" "_"))))
+
+(define* (object->camel-case-string object #:optional (style 'lower))
+ "Convert the object OBJECT to the equivalent string in ``camel case''.
+STYLE can be three `@code{lower}', `@code{upper}', defaults to
+`@code{lower}'.
+
+@example
+(object->camel-case-string 'variable-name 'upper)
+@result{} \"VariableName\"
+@end example"
+ (if (not (member style '(lower upper)))
+ (error 'invalid-style (format #f "~a is not a valid style" style))
+ (let ((stringified (maybe-object->string object)))
+ (cond
+ ((eq? style 'upper)
+ (string-concatenate
+ (map string-capitalize
+ (string-split stringified (cut eqv? <> #\-)))))
+ ((eq? style 'lower)
+ (let ((splitted-string (string-split stringified (cut eqv? <> #\-))))
+ (string-concatenate
+ (cons (first splitted-string)
+ (map string-capitalize
+ (cdr splitted-string))))))))))
diff --git a/gnu/local.mk b/gnu/local.mk
index 24b95565d2..8c3c528663 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -79,6 +79,7 @@ GNU_SYSTEM_MODULES = \
%D%/home-services/fontutils.scm \
%D%/home-services/configuration.scm \
%D%/home-services/shells.scm \
+ %D%/home-services/utils.scm \
%D%/home-services/xdg.scm \
%D%/image.scm \
%D%/packages.scm \