summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:45:42 +0200
commite13de8715ffe98b707d4702ddd67d300017f5aa3 (patch)
tree5bf22c6f504a801cb77c5dee21692846a6f1ee4a /gnu
parent87682c88c858a2b545b347ad951524f14bd98633 (diff)
downloadguix-patches-e13de8715ffe98b707d4702ddd67d300017f5aa3.tar
guix-patches-e13de8715ffe98b707d4702ddd67d300017f5aa3.tar.gz
gnu: Add r-crul.
* gnu/packages/cran.scm (r-crul): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a66ec87adc..64008c97e0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31193,3 +31193,32 @@ or 53. MMWR week #1 of an MMWR year is the first week of the year that has at
least four days in the calendar year. This package provides functionality to
convert dates to MMWR day, week, and year and the reverse.")
(license license:gpl2+)))
+
+(define-public r-crul
+ (package
+ (name "r-crul")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "crul" version))
+ (sha256
+ (base32
+ "1kjsc5gkx5k5cfwlfjp2cjm9cdzq2l1m68bnrjmahw3lkz8wzdph"))))
+ (properties `((upstream-name . "crul")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-curl" ,r-curl)
+ ("r-httpcode" ,r-httpcode)
+ ("r-jsonlite" ,r-jsonlite)
+ ("r-mime" ,r-mime)
+ ("r-r6" ,r-r6)
+ ("r-urltools" ,r-urltools)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/ropensci/crul")
+ (synopsis "HTTP client")
+ (description
+ "This package provides a simple HTTP client, with tools for making HTTP
+requests, and mocking HTTP requests. The package is built on R6, and takes
+inspiration from Ruby's @code{faraday} gem.")
+ (license license:expat)))