summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-23 16:32:33 +0200
committerMarius Bakke <marius@gnu.org>2020-06-24 01:04:15 +0200
commitac944584859a77c84eaff3240416b97d230db1ff (patch)
tree2a49aabb0a8f77b40220e7a311154030ce4fa84e /gnu
parent09f0bc87a9efa2106b8b5333abc55f4db1b55cc4 (diff)
downloadguix-patches-ac944584859a77c84eaff3240416b97d230db1ff.tar
guix-patches-ac944584859a77c84eaff3240416b97d230db1ff.tar.gz
gnu: python-on-guile: Update to 1.2.3.4.
* gnu/packages/guile-xyz.scm (python-on-guile): Update to 1.2.3. [source]: Download from <https://gitlab.com/python-on-guile/python-on-guile>. [inputs]: Change from GUILE-2.2 to GUILE-3.0. [arguments]: Add phase augment-GUILE_LOAD_PATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm103
1 files changed, 53 insertions, 50 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index db04f23fee..19b5284d5b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2572,57 +2572,60 @@ serializing continuations or delimited continuations.")
(license license:lgpl2.0+)))
(define-public python-on-guile
- (let ((commit "00a51a23247f1edc4ae8eda72b30df5cd7d0015f")
- (revision "3"))
- (package
- (name "python-on-guile")
- (version (git-version "0.1.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.elephly.net/software/python-on-guile.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "03rpnqr08rqr3gay128g564rwk8w4jbj28ss6b46z1d4vjs4nk68"))))
- (build-system gnu-build-system)
- (arguments
- `(#:parallel-build? #f ; not supported
- #:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
-
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'chdir
- (lambda _ (chdir "modules") #t))
- (add-after 'install 'wrap
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Wrap the 'python' executable so it can find its
- ;; dependencies.
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/python")
- `("GUILE_LOAD_PATH" ":" prefix
- (,(getenv "GUILE_LOAD_PATH")))
- `("GUILE_LOAD_COMPILED_PATH" ":" prefix
- (,(getenv "GUILE_LOAD_COMPILED_PATH"))))
- #t))))))
- (inputs
- `(("guile" ,guile-2.2)))
- (propagated-inputs
- `(("guile-persist" ,guile-persist)
- ("guile-readline" ,guile-readline)
- ("guile-stis-parser" ,guile-stis-parser)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
- (home-page "https://gitlab.com/python-on-guile/python-on-guile/")
- (synopsis "Python implementation in Guile")
- (description
- "This package allows you to compile a Guile Python file to any target
+ (package
+ (name "python-on-guile")
+ (version "1.2.3.4")
+ (home-page "https://gitlab.com/python-on-guile/python-on-guile")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qn5f79z43jh0rqh39a0qal81nsnw3cd5pj0d1j5cm3nhj5s64a7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-build? #f ;not supported
+ #:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "modules") #t))
+ (add-after 'chdir 'augment-GUILE_LOAD_PATH
+ (lambda _
+ ;; TODO: It would be better to patch the Makefile.
+ (setenv "GUILE_LOAD_PATH"
+ (string-append ".:"
+ (getenv "GUILE_LOAD_PATH")))
+ #t))
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Wrap the 'python' executable so it can find its
+ ;; dependencies.
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/python")
+ `("GUILE_LOAD_PATH" ":" prefix
+ (,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix
+ (,(getenv "GUILE_LOAD_COMPILED_PATH"))))
+ #t))))))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (propagated-inputs
+ `(("guile-persist" ,guile-persist)
+ ("guile-readline" ,guile-readline)
+ ("guile-stis-parser" ,guile-stis-parser)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Python implementation in Guile")
+ (description
+ "This package allows you to compile a Guile Python file to any target
from @code{tree-il}.")
- (license license:lgpl2.0+))))
+ (license license:lgpl2.0+)))
(define-public guile-file-names
(package