summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-23 23:14:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-23 23:15:55 +0200
commit88e0101b61af45584d36af541c499258d037f2ac (patch)
tree0806f58b5cf5bc1c9342b2ec1c756367453a3064 /gnu
parent6bd9e0d50197cf08d2456d0c93b4711ed588622c (diff)
downloadguix-patches-88e0101b61af45584d36af541c499258d037f2ac.tar
guix-patches-88e0101b61af45584d36af541c499258d037f2ac.tar.gz
gnu: Add python-imageio.
* gnu/packages/python-xyz.scm (python-imageio): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7eee3b6888..4171ab660f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5392,6 +5392,43 @@ converting, and viewing many of the proprietary file formats used to store
experimental data and metadata at the Laboratory for Fluorescence Dynamics.")
(license license:bsd-3)))
+(define-public python-imageio
+ (package
+ (name "python-imageio")
+ (version "2.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "imageio" version))
+ (sha256
+ (base32
+ "1ksjl523fm0fikrd85llxfba35rc1qsgwadgr6mbn9kis79xcpzv"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f ; many tests require online data
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key outputs inputs tests? #:allow-other-keys)
+ (if tests?
+ (begin
+ ;; Make installed package available for running the tests.
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv"))
+ #t))))))
+ (propagated-inputs
+ `(("python-numpy" ,python-numpy)
+ ("python-pillow" ,python-pillow)
+ ("python-psutil" ,python-psutil)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/imageio/imageio")
+ (synopsis "Read and write image, video, scientific, and volumetric data formats")
+ (description
+ "This package provides a Python library for reading and writing a wide
+range of image, video, scientific, and volumetric data formats.")
+ (license license:bsd-2)))
+
(define-public python-pycparser
(package
(name "python-pycparser")