summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-02-08 00:15:48 +0100
committerLudovic Courtès <ludo@gnu.org>2013-02-08 00:15:48 +0100
commit87d836b2c9087eb81c4f113191d829474a40ed96 (patch)
tree5f5cadba5276cad8c6e0c83859438d0d983bf181 /gnu
parent2f4fbe1cb36253cabf2afea38f6674c2f88cc191 (diff)
downloadguix-patches-87d836b2c9087eb81c4f113191d829474a40ed96.tar
guix-patches-87d836b2c9087eb81c4f113191d829474a40ed96.tar.gz
gnu: Add GNU mcron.
* gnu/packages/guile.scm (mcron): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index e36c0c2a2e..729a921346 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -30,6 +30,8 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages readline)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages ed)
+ #:use-module (gnu packages which)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -238,4 +240,32 @@ functionality is built on the ncurses libraries: curses, form, panel, and
menu.")
(license lgpl3+)))
+(define-public mcron
+ (package
+ (name "mcron")
+ (version "1.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/mcron/mcron-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0yvrfzzdy2m7fbqkr61fw01wd9r2jpnbyabxhcsfivgxywknl0fy"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:patches (list (assoc-ref %build-inputs "patch/install"))))
+ (inputs
+ `(("ed" ,ed) ("which" ,which) ("guile" ,guile-1.8)
+ ("patch/install" ,(search-patch "mcron-install.patch"))))
+ (home-page "http://www.gnu.org/software/mcron/")
+ (synopsis
+ "GNU mcron, a flexible implementation of `cron' in Guile")
+ (description
+ "The GNU package mcron (Mellor's cron) is a 100% compatible replacement
+for Vixie cron. It is written in pure Guile, and allows configuration files
+to be written in scheme (as well as Vixie's original format) for infinite
+flexibility in specifying when jobs should be run. Mcron was written by Dale
+Mellor.")
+ (license gpl3+)))
+
;;; guile.scm ends here