summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCollin J. Doering <collin@rekahsoft.ca>2021-12-26 22:36:17 -0500
committerLudovic Courtès <ludo@gnu.org>2022-01-01 15:11:42 +0100
commit66b87c5d98923e3a5f82f09e621bba98d387d862 (patch)
tree5e91962445cd5cda608ffdc70310e45992a7f7f8 /gnu
parent03a143a84b3ad92fa0d3c60d48c2539fb1ec48da (diff)
downloadguix-patches-66b87c5d98923e3a5f82f09e621bba98d387d862.tar
guix-patches-66b87c5d98923e3a5f82f09e621bba98d387d862.tar.gz
gnu: Add go-github-com-androiddnsfix
* gnu/packages/golang.scm (go-github-com-androiddnsfix): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3fe16582f2..6ef76dba99 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8965,3 +8965,29 @@ Currently Keyring supports the following backends: macOS/OSX Keychain, Windows
pcredential store, Pass, Secret Service, KDE Wallet, Encrypted File.")
(home-page "https://github.com/99designs/keyring")
(license license:expat)))
+
+(define-public go-github-com-androiddnsfix
+ (let ((commit "ff02804463540c36e3a148dcf4b009d003cf2a31")
+ (revision "0"))
+ (package
+ (name "go-github-com-androiddnsfix")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mtibben/androiddnsfix")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1pcbjs793kd0yg3dcp79agfxm7xm3sldx2r7v66ipzpcq0j2npi2"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mtibben/androiddnsfix"
+ #:phases %standard-phases))
+ (synopsis "Hack to get around the issues building on android")
+ (description
+ "Hack around the issues in https://github.com/golang/go/issues/8877.")
+ (home-page "https://github.com/mtibben/androiddnsfix")
+ (license license:expat))))
+