summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-28 00:56:02 -0500
committerLeo Famulari <leo@famulari.name>2016-03-13 18:52:30 -0400
commit61c30e9d2388744ea712536c4397a18d8c1c2614 (patch)
treefb36372c7399660535c426c2b0f97c2ea7914683 /gnu
parenteed1a61fbbae973defa81a886080dd743c12c828 (diff)
downloadguix-patches-61c30e9d2388744ea712536c4397a18d8c1c2614.tar
guix-patches-61c30e9d2388744ea712536c4397a18d8c1c2614.tar.gz
gnu: Add khard.
* gnu/packages/mail.scm (khard): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm47
1 files changed, 44 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 67be224c23..5bc6434424 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -71,8 +71,8 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module ((guix licenses)
- #:select (gpl2 gpl2+ gpl3+ lgpl2.1 lgpl2.1+ lgpl3+ non-copyleft
- (expat . license:expat)))
+ #:select (gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 lgpl2.1+ lgpl3+
+ non-copyleft (expat . license:expat)))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -1150,5 +1150,46 @@ maintained.")
;; nonfree Artistic License 1.0
;; as alternative to the GPL2+.
;; This option is not listed here.
-;;; mail.scm ends here
+(define-public khard
+ (package
+ (name "khard")
+ (version "0.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri name version))
+ (sha256
+ (base32
+ "098gs94qmnspdfn6ar8lycx7dbsz9bcff90aps0cmn47mw7llch0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ; only python-2 is supported.
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'disable-egg-compression
+ ;; Do not compress the egg.
+ (lambda _
+ (let ((port (open-file "setup.cfg" "a")))
+ (display "\n[easy_install]\nzip_ok = 0\n"
+ port)
+ (close-port port)
+ #t)))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/khard")))
+ (copy-recursively "misc/khard" doc)))))))
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)))
+ (propagated-inputs
+ `(("python2-vobject" ,python2-vobject)
+ ("python2-pyyaml" ,python2-pyyaml)
+ ("python2-atomicwrites" ,python2-atomicwrites)
+ ("python2-configobj" ,python2-configobj)))
+ (synopsis "Console address book using CardDAV")
+ (description "Khard is an address book for the console. It creates, reads,
+modifies and removes CardDAV address book entries at your local machine. For
+synchronizing with a remote address book, @command{vdirsyncer} is recommended.
+Khard can also be used from within the email client @command{mutt}.")
+ (home-page "https://github.com/scheibler/khard")
+ (license gpl3+)))