summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-03-08 22:47:01 +0100
committerAndreas Enge <andreas@enge.fr>2013-03-08 22:47:01 +0100
commit322cbda7c5e89e9393310555e3158b83b24c713c (patch)
treeb6bf1bd44ead6e4aabbfd1d3754c5d1330933961 /gnu
parentf8d3c99ba1f1cd0493e2cbdfdf022d5664958511 (diff)
downloadguix-patches-322cbda7c5e89e9393310555e3158b83b24c713c.tar
guix-patches-322cbda7c5e89e9393310555e3158b83b24c713c.tar.gz
gnu: libxml2: Add python support.
* gnu/packages/xml.scm (libxml2): Compile and install python module.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b3c5f7d512..ab9fd4bffc 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -19,6 +19,7 @@
(define-module (gnu packages xml)
#:use-module (gnu packages)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages perl)
#:use-module (gnu packages python)
@@ -64,7 +65,21 @@ things the parser might find in the XML document (like start tags).")
(home-page "http://www.xmlsoft.org/")
(synopsis "libxml2, a C parser for XML")
(inputs `(("perl" ,perl)
- ("python" ,python)))
+ ("python" ,python)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'install
+ (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+ (let ((install (assoc-ref %standard-phases 'install))
+ (glibc (assoc-ref inputs "libc"))
+ (out (assoc-ref outputs "out")))
+ (apply install args)
+ (chdir "python")
+ (substitute* "setup.py" (("/opt/include") (string-append glibc "/include")))
+ (system* "python" "setup.py" "install" (string-append "--prefix=" out))))
+ %standard-phases)))
(description
"Libxml2 is the XML C parser and toolkit developed for the Gnome project
(but it is usable outside of the Gnome platform).")