summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-12-23 19:06:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-29 17:40:28 +0100
commit2a4322f7c34b3cf81ae3ff39527404c22e68399a (patch)
tree4d1141e55f34fffa188c6e71e09d12de15886e74 /gnu
parent69a5e066c17452f3ef7843451510ae818184324b (diff)
downloadguix-patches-2a4322f7c34b3cf81ae3ff39527404c22e68399a.tar
guix-patches-2a4322f7c34b3cf81ae3ff39527404c22e68399a.tar.gz
gnu: r-gviz: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-gviz): Move from here... * gnu/packages/bioconductor.scm (r-gviz): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm49
-rw-r--r--gnu/packages/bioinformatics.scm49
2 files changed, 49 insertions, 49 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 970602a32b..11e9a46b11 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9241,6 +9241,55 @@ preprocessing of cytometry data, including i) normalization using bead
standards, ii) single-cell deconvolution, and iii) bead-based compensation.")
(license license:gpl2+)))
+(define-public r-gviz
+ (package
+ (name "r-gviz")
+ (version "1.34.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Gviz" version))
+ (sha256
+ (base32
+ "0v7bz46b91dnrr55ah42ljj1i2xs3090s4w0lw8098pag00p4vh2"))))
+ (properties `((upstream-name . "Gviz")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-biomart" ,r-biomart)
+ ("r-biostrings" ,r-biostrings)
+ ("r-biovizbase" ,r-biovizbase)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-digest" ,r-digest)
+ ("r-ensembldb" ,r-ensembldb)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-iranges" ,r-iranges)
+ ("r-lattice" ,r-lattice)
+ ("r-latticeextra" ,r-latticeextra)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-s4vectors" ,r-s4vectors)
+ ("r-xvector" ,r-xvector)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/Gviz")
+ (synopsis "Plotting data and annotation information along genomic coordinates")
+ (description
+ "Genomic data analyses requires integrated visualization of known genomic
+information and new experimental data. Gviz uses the biomaRt and the
+rtracklayer packages to perform live annotation queries to Ensembl and UCSC
+and translates this to e.g. gene/transcript structures in viewports of the
+grid graphics package. This results in genomic information plotted together
+with your data.")
+ (license license:artistic2.0)))
+
(define-public r-gwascat
(package
(name "r-gwascat")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ab187dcddd..caa505fdab 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -10785,55 +10785,6 @@ interpretation of members of a collection of association statistics on a
family of feature/genome hypotheses.")
(license license:artistic2.0)))
-(define-public r-gviz
- (package
- (name "r-gviz")
- (version "1.34.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "Gviz" version))
- (sha256
- (base32
- "0v7bz46b91dnrr55ah42ljj1i2xs3090s4w0lw8098pag00p4vh2"))))
- (properties `((upstream-name . "Gviz")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotationdbi" ,r-annotationdbi)
- ("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-biomart" ,r-biomart)
- ("r-biostrings" ,r-biostrings)
- ("r-biovizbase" ,r-biovizbase)
- ("r-bsgenome" ,r-bsgenome)
- ("r-digest" ,r-digest)
- ("r-ensembldb" ,r-ensembldb)
- ("r-genomeinfodb" ,r-genomeinfodb)
- ("r-genomicalignments" ,r-genomicalignments)
- ("r-genomicfeatures" ,r-genomicfeatures)
- ("r-genomicranges" ,r-genomicranges)
- ("r-iranges" ,r-iranges)
- ("r-lattice" ,r-lattice)
- ("r-latticeextra" ,r-latticeextra)
- ("r-matrixstats" ,r-matrixstats)
- ("r-rcolorbrewer" ,r-rcolorbrewer)
- ("r-rsamtools" ,r-rsamtools)
- ("r-rtracklayer" ,r-rtracklayer)
- ("r-s4vectors" ,r-s4vectors)
- ("r-xvector" ,r-xvector)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/Gviz")
- (synopsis "Plotting data and annotation information along genomic coordinates")
- (description
- "Genomic data analyses requires integrated visualization of known genomic
-information and new experimental data. Gviz uses the biomaRt and the
-rtracklayer packages to perform live annotation queries to Ensembl and UCSC
-and translates this to e.g. gene/transcript structures in viewports of the
-grid graphics package. This results in genomic information plotted together
-with your data.")
- (license license:artistic2.0)))
-
(define-public r-dropbead
(let ((commit "d746c6f3b32110428ea56d6a0001ce52a251c247")
(revision "2"))