summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-25 18:38:09 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-25 18:38:09 +0200
commit24a472d9d58f6236497f197326f4ba194b918b23 (patch)
tree9f0105e9c9ebe795427ffa682a82d86d319c85e1 /gnu
parent42298953bad9f56379810d39295f1f79cabad4be (diff)
downloadguix-patches-24a472d9d58f6236497f197326f4ba194b918b23.tar
guix-patches-24a472d9d58f6236497f197326f4ba194b918b23.tar.gz
gnu: libgdata: Fix tests.
* gnu/packages/gnome.scm (libgdata)[arguments]: Add 'set-home-for-tests' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b23fe4a662..1e7f16dcd8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -60,6 +60,7 @@
;;; Copyright © 2020, 2021 Sébastien Lerique <sl@eauchat.org>
;;; Copyright © 2021 Trevor Hass <thass@okstate.edu>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1947,13 +1948,15 @@ formats like PNG, SVG, PDF and EPS.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-before 'check 'set-home-for-tests
+ (lambda _
+ (setenv "HOME" "/tmp")))
(add-before 'check 'disable-failing-tests
(lambda _
;; The PicasaWeb API tests fail with gnome-online-accounts@3.24.2.
;; They have been removed in libgdata 0.17.6, so just do the same.
(substitute* "gdata/tests/Makefile"
- (("picasaweb\\$\\(EXEEXT\\) ") ""))
- #t)))))
+ (("picasaweb\\$\\(EXEEXT\\) ") "")))))))
(native-inputs
`(("glib:bin" ,glib "bin")
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)