summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-26 17:01:10 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-26 17:01:10 +0200
commit11acdf1747a18fe11ccbabb78b5b14884164ee39 (patch)
treed851b657a0ddf57337409b82666775d5b4b14fc3 /gnu
parentde1d41f9807dec9cc8a151af60e4949aa62b25d6 (diff)
downloadguix-patches-11acdf1747a18fe11ccbabb78b5b14884164ee39.tar
guix-patches-11acdf1747a18fe11ccbabb78b5b14884164ee39.tar.gz
gnu: make-bootstrap: Have %gcc-static actually static when cross building.
* gnu/packages/make-bootstrap.scm (%gcc-static): Pass `-static' through `LDFLAGS' when cross-compiling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/make-bootstrap.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 13f858adc6..853dc8e59d 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -389,7 +389,9 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(remove (cut string-match "--(.*plugin|enable-languages)" <>)
,flags)))
((#:make-flags flags)
- `(cons "BOOT_LDFLAGS=-static" ,flags)))))
+ (if (%current-target-system)
+ `(cons "LDFLAGS=-static" ,flags)
+ `(cons "BOOT_LDFLAGS=-static" ,flags))))))
(inputs `(("gmp-source" ,(package-source gmp))
("mpfr-source" ,(package-source mpfr))
("mpc-source" ,(package-source mpc))