summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRyan Prior <rprior@protonmail.com>2021-09-27 02:20:22 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-15 17:55:50 +0100
commitf661fa8e8f23bdaf854bcde6656f865f5d34ae84 (patch)
treed723025e19906511df37f3e91da83d6b41ece62b /gnu
parent37e6f028804aa63648534e1f533913b5c93265f8 (diff)
downloadguix-patches-f661fa8e8f23bdaf854bcde6656f865f5d34ae84.tar
guix-patches-f661fa8e8f23bdaf854bcde6656f865f5d34ae84.tar.gz
gnu: Add python-etuples.
* gnu/packages/python-xyz.scm (python-etuples): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3462704223..c6d0d97239 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27445,6 +27445,27 @@ symbolic expressions in pure Python using the technique of logical unification."
cons cells in Python.")
(license license:lgpl3+)))
+(define-public python-etuples
+ (package
+ (name "python-etuples")
+ (version "0.3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "etuples" version))
+ (sha256
+ (base32
+ "0jhfyp177v37rl0i7wqfx7q6s5qkz027hl283d1x8d0vm3w0zqc8"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cons" ,python-cons)
+ ("python-multipledispatch" ,python-multipledispatch)))
+ (home-page "https://github.com/pythological/etuples")
+ (synopsis "S-expressions in Python")
+ (description
+ "This library implements eval'able S-expression in Python using tuple-like objects.")
+ (license license:asl2.0)))
+
(define-public date2name
(let ((commit "6c8f37277e8ec82aa50f90b8921422be30c4e798")
(revision "1"))