summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-25 20:24:23 -0400
committerLeo Famulari <leo@famulari.name>2017-07-26 12:06:52 -0400
commitf96dbf6b70364518072c63037d3fca105dfe6497 (patch)
tree14109dd53f759afe36a95a919cd27314067d5ee9 /gnu
parentbcd757fdb49753f41a7ee4f0181cdef582705a6a (diff)
downloadguix-patches-f96dbf6b70364518072c63037d3fca105dfe6497.tar
guix-patches-f96dbf6b70364518072c63037d3fca105dfe6497.tar.gz
gnu: net-tools: Add a test-only variant and use it for GnuTLS.
* gnu/packages/linux.scm (net-tools-for-tests): Add hidden net-tools variant. * gnu/packages/tls.scm (gnutls)[native-inputs]: Use net-tools-for-tests instead of net-tools.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm3
-rw-r--r--gnu/packages/tls.scm5
2 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 456909a940..7412ee5717 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1288,6 +1288,9 @@ network hardware types (plipconfig, slattach) and advanced aspects of IP
configuration (iptunnel, ipmaddr).")
(license license:gpl2+)))
+(define-public net-tools-for-tests
+ (hidden-package net-tools))
+
(define-public libcap
(package
(name "libcap")
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 0a81633aa7..b39e06c8d9 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -140,6 +140,9 @@ coordinating the use of PKCS#11 by different components or libraries
living in the same process.")
(license license:bsd-3)))
+
+;; TODO Add net-tools-for-tests to #:disallowed-references when we can afford
+;; rebuild GnuTLS (i.e. core-updates).
(define-public gnutls
(package
(name "gnutls")
@@ -194,7 +197,7 @@ living in the same process.")
"debug"
"doc")) ;4.1 MiB of man pages
(native-inputs
- `(("net-tools" ,net-tools)
+ `(("net-tools" ,net-tools-for-tests)
("pkg-config" ,pkg-config)
("which" ,which)))
(inputs