summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:05:29 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commitd4b77f3662fd903be432a268f5076191cd0da777 (patch)
tree4aa5cab506483e0e220ed9629519df505f2f7b22 /gnu
parentf404b5ea6e52ed14640d42e84858fc16a9b42091 (diff)
downloadguix-patches-d4b77f3662fd903be432a268f5076191cd0da777.tar
guix-patches-d4b77f3662fd903be432a268f5076191cd0da777.tar.gz
gnu: Add python-zope-security.
* gnu/packages/python.scm (python-zope-security, python2-zope-security): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9ba4388e7c..41ac5becd4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6278,3 +6278,33 @@ Zope3, which are are special objects that have a structural location.")
(define-public python2-zope-location
(package-with-python2 python-zope-location))
+
+(define-public python-zope-security
+ (package
+ (name "python-zope-security")
+ (version "4.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/z"
+ "/zope.security/zope.security-" version ".tar.gz"))
+ (sha256
+ (base32
+ "14zmf684amc0x32kq05yxnhfqd1cmyhafkw05gn81rn90zjv6ssy"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-zope-i18nmessageid" ,python-zope-i18nmessageid)
+ ("python-zope-component" ,python-zope-component)
+ ("python-zope-location" ,python-zope-location)
+ ("python-zope-proxy" ,python-zope-proxy)
+ ("python-zope-schema" ,python-zope-schema)
+ ("python-zope-testrunner" ,python-zope-testrunner)
+ ("python-zope-testing" ,python-zope-testing)))
+ (home-page "http://pypi.python.org/pypi/zope.security")
+ (synopsis "Zope security framework")
+ (description "Zope.security provides a generic mechanism to implement
+security policies on Python objects.")
+ (license zpl2.1)))
+
+(define-public python2-zope-security
+ (package-with-python2 python-zope-security))