summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 03:28:34 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commit3859ac12d6a5648d8cfc7d521218c0d582b6d4c5 (patch)
tree54110aad90d668d6ba23c8996d6225dee005714b /gnu
parenta6b61b271b4abd3ad3c31504d170d5e8f9536cb2 (diff)
downloadguix-patches-3859ac12d6a5648d8cfc7d521218c0d582b6d4c5.tar
guix-patches-3859ac12d6a5648d8cfc7d521218c0d582b6d4c5.tar.gz
gnu: Add python-pyrfc3339.
* gnu/packages/python.scm (python-pyrfc3339, python2-pyrfc3339): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d6b43fdae5..6923724488 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6341,3 +6341,30 @@ facilities for defining, registering and looking up components.")
(define-public python2-zope-component
(package-with-python2 python-zope-component))
+
+(define-public python-pyrfc3339
+ (package
+ (name "python-pyrfc3339")
+ (version "0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p/"
+ "pyRFC3339/pyRFC3339-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pp648xsjaw9h1xq2mgwzda5wis2ypjmzxlksc1a8grnrdmzy155"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytz" ,python-pytz)))
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/kurtraschke/pyRFC3339")
+ (synopsis "Python timestamp library")
+ (description "Python library for generating and parsing RFC 3339-compliant
+timestamps.")
+ (license license:expat)))
+
+(define-public python2-pyrfc3339
+ (package-with-python2 python-pyrfc3339))