summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-17 14:57:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-17 14:57:26 +0200
commit7b199d83604e2f7091649922e1a63add89f94aab (patch)
treed4f2e4fb3ba5e4a17a82fa33cda15e33d30c5e90 /gnu
parent88d8b4ece08a54fe7596c38fee860b5ee95e6565 (diff)
downloadguix-patches-7b199d83604e2f7091649922e1a63add89f94aab.tar
guix-patches-7b199d83604e2f7091649922e1a63add89f94aab.tar.gz
gnu: Add r-delaporte.
* gnu/packages/cran.scm (r-delaporte): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2e7e9041c6..e01b2417d2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29157,6 +29157,34 @@ Xiaohui Yan, Jiafeng Guo, Yanyan Lan, Xueqi Cheng (2013)
BTM-WWW13.pdf}.")
(license license:asl2.0)))
+(define-public r-delaporte
+ (package
+ (name "r-delaporte")
+ (version "8.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Delaporte" version))
+ (sha256
+ (base32
+ "0ijhmwclpg5czs2sl2vykcw8qj2pxy26xf6knh62rqq6p6sm43f4"))))
+ (properties `((upstream-name . "Delaporte")))
+ (build-system r-build-system)
+ (native-inputs `(("gfortran" ,gfortran)))
+ (home-page "https://github.com/aadler/Delaporte")
+ (synopsis "Statistical functions for the Delaporte distribution")
+ (description
+ "This package provides probability mass, distribution, quantile,
+random-variate generation, and method-of-moments parameter-estimation
+functions for the Delaporte distribution with parameterization based on
+Vose (2008). The Delaporte is a discrete probability distribution which can
+be considered the convolution of a negative binomial distribution with a
+Poisson distribution. Alternatively, it can be considered a counting
+distribution with both Poisson and negative binomial components. It has been
+studied in actuarial science as a frequency distribution which has more
+variability than the Poisson, but less than the negative binomial.")
+ (license license:bsd-2)))
+
(define-public r-rjsonio
(package
(name "r-rjsonio")