summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-22 14:58:16 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-12 16:08:18 +0200
commitcb6d5c5468f42f52e82596c7e46bac4a25f3c52a (patch)
treea8c86e802442656f07281e93fdb0a2941a5d9613 /gnu
parentdb94f8c7344056c39658bf3c2131fceaf80d0a12 (diff)
downloadguix-patches-cb6d5c5468f42f52e82596c7e46bac4a25f3c52a.tar
guix-patches-cb6d5c5468f42f52e82596c7e46bac4a25f3c52a.tar.gz
gnu: Add python-pexpect.
* gnu/packages/python.scm (python-pexpect, python2-pexpect): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 32b1678f96..b999b832cc 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3733,6 +3733,36 @@ cluster without needing to write any wrapper code yourself.")
(define-public python2-gridmap
(package-with-python2 python-gridmap))
+(define-public python-pexpect
+ (package
+ (name "python-pexpect")
+ (version "3.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p/"
+ "pexpect/pexpect-" version ".tar.gz"))
+ (sha256
+ (base32 "1fp5gm976z7ghm8jw57463rj19cv06c8zw842prgyg788f6n3snz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check (lambda _ (zero? (system* "nosetests")))))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "http://pexpect.readthedocs.org/")
+ (synopsis "Controlling interactive console applications")
+ (description
+ "Pexpect is a pure Python module for spawning child applications;
+controlling them; and responding to expected patterns in their output.
+Pexpect works like Don Libes’ Expect. Pexpect allows your script to spawn a
+child application and control it as if a human were typing commands.")
+ (license isc)))
+
+(define-public python2-pexpect
+ (package-with-python2 python-pexpect))
+
(define-public python-ipython
(package
(name "python-ipython")