summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-23 12:48:27 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-12 16:08:18 +0200
commit0d34e01b62ea451e6584010c7c7a6db8e6e211ed (patch)
tree2c2702e227be373883a27a0c1c6c18a2f9223448 /gnu
parentb74270eedb036d747aa65a52d45b6095d30becf2 (diff)
downloadguix-patches-0d34e01b62ea451e6584010c7c7a6db8e6e211ed.tar
guix-patches-0d34e01b62ea451e6584010c7c7a6db8e6e211ed.tar.gz
gnu: Add python-pickleshare.
* gnu/packages/python.scm (python-pickleshare, python2-pickleshare): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index cf09bf4f1a..41b08cfde7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3853,6 +3853,35 @@ common operations on files to be invoked on those path objects directly.")
(define-public python2-pathpy
(package-with-python2 python-pathpy))
+(define-public python-pickleshare
+ (package
+ (name "python-pickleshare")
+ (version "0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p/"
+ "pickleshare/pickleshare-" version ".tar.gz"))
+ (sha256
+ (base32 "11ljr90j3p6qswdrbl7p4cjb2i93f6vn0vx9anzpshsx0d2mggn0"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pathpy" ,python-pathpy)))
+ (home-page "https://github.com/vivainio/pickleshare")
+ (synopsis "Tiny key value database with concurrency support")
+ (description
+ "PickleShare is a small ‘shelve’-like datastore with concurrency support.
+Like shelve, a PickleShareDB object acts like a normal dictionary. Unlike
+shelve, many processes can access the database simultaneously. Changing a
+value in database is immediately visible to other processes accessing the same
+database. Concurrency is possible because the values are stored in separate
+files. Hence the “database” is a directory where all files are governed by
+PickleShare.")
+ (license license:expat)))
+
+(define-public python2-pickleshare
+ (package-with-python2 python-pickleshare))
+
(define-public python-ipython
(package
(name "python-ipython")