summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-08-03 22:46:14 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-03 22:46:14 +0200
commitc8737b1e41f7ef5c730fb0b47c5b478ab58b2341 (patch)
treef23b8a3170aa2662002ce9fd5ccfcc5c7927dd28 /gnu
parentaa9780daf92131dc9ee19868f9621fd2be56ab78 (diff)
downloadguix-patches-c8737b1e41f7ef5c730fb0b47c5b478ab58b2341.tar
guix-patches-c8737b1e41f7ef5c730fb0b47c5b478ab58b2341.tar.gz
gnu: icedtea@3.5.0: Properly handle decoding error while substituting.
* gnu/packages/java.scm (icedtea-8)[arguments] <patch-jni-libs>: Change 'encoding-error to 'decoding-error, which is what Guile 2.2 raises when failing to decode an input file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 5744db6ebc..47dd4f256b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1602,7 +1602,7 @@ IcedTea build harness.")
(string-append "lib" name ".so")))))
(for-each
(lambda (file)
- (catch 'encoding-error
+ (catch 'decoding-error
(lambda ()
(substitute* file
(("VERSIONED_JNI_LIB_NAME\\(\"(.*)\", \"(.*)\"\\)"