summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-22 07:15:52 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-22 08:57:32 +0100
commitb5016027a01d75f8be9a24819056c37756eaea12 (patch)
tree37c30120b28a2405a9129c324bb1b4276bb583cc /gnu
parentb033079e47357dcf77ebeeb52b0a5306cd6aa982 (diff)
downloadguix-patches-b5016027a01d75f8be9a24819056c37756eaea12.tar
guix-patches-b5016027a01d75f8be9a24819056c37756eaea12.tar.gz
gnu: Add python-update-checker.
* gnu/packages/python-xyz.scm (python-update-checker): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10d2f08705..0dbf23ebb8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21530,6 +21530,25 @@ interface to FUSE on various operating systems. It's just one file and is
implemented using @code{ctypes}.")
(license license:isc)))
+(define-public python-update-checker
+ (package
+ (name "python-update-checker")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "update-checker" version))
+ (sha256
+ (base32 "04yb5a9mi45ax50m2m0ih6gdvkk1j7gfmy83dd58i1f59axlabba"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-requests))
+ (native-inputs (list python-black python-flake8 python-pytest))
+ (home-page "https://github.com/bboe/update_checker")
+ (synopsis "Python module that will check for package updates")
+ (description "This package provides a Python module that will check for
+package updates.")
+ (license license:bsd-2)))
+
(define-public python-userspacefs
(package
(name "python-userspacefs")