summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-23 15:27:56 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-16 15:43:51 +0200
commit6347ac8e407fff377e2b5810e0b1b850b3bfcc1d (patch)
tree7f6212042f7729845d050aec7a1d94dedc20ecc0 /gnu
parentc10ba562be86ff29612372b4d70bec75368eb0e8 (diff)
downloadguix-patches-6347ac8e407fff377e2b5810e0b1b850b3bfcc1d.tar
guix-patches-6347ac8e407fff377e2b5810e0b1b850b3bfcc1d.tar.gz
gnu: Add ocaml4.07-bisect-ppx.
* gnu/packages/ocaml.scm (ocaml4.07-bisect-ppx): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f25189c3db..2aeffcf9ac 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6617,7 +6617,8 @@ combinators.")
(arguments
;; Tests require ocamlformat which would lead to circular dependencies
'(#:tests? #f))
- (properties '((upstream-name . "bisect_ppx")))
+ (properties `((upstream-name . "bisect_ppx")
+ (ocaml4.07-variant . ,(delay ocaml4.07-bisect-ppx))))
(home-page "https://github.com/aantron/bisect_ppx")
(synopsis "Code coverage for OCaml")
(description "Bisect_ppx helps you test thoroughly. It is a small
@@ -6629,6 +6630,33 @@ Usage is simple - add package bisect_ppx when building tests, run your tests,
then run the Bisect_ppx report tool on the generated visitation files.")
(license license:mpl2.0)))
+(define-public ocaml4.07-bisect-ppx
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-bisect-ppx)
+ (version "2.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aantron/bisect_ppx")
+ (commit version)))
+ (file-name (git-file-name "ocaml-bisect-ppx" version))
+ (sha256
+ (base32
+ "1njs8xc108rrpx5am5zhhcn6vjva7rsphm8034qp5lgyvnhfgh7q"))))
+ (propagated-inputs
+ `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
+ ,@(package-propagated-inputs ocaml-bisect-ppx)))
+ (native-inputs
+ `(("ocaml-ounit2" ,ocaml-ounit2)))
+ (arguments
+ `(#:test-target "."
+ ;; tests require git and network
+ #:tests? #f))
+ (properties '((upstream-name . "bisect_ppx"))))))
+
(define-public ocaml-odoc
(package
(name "ocaml-odoc")