summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-09-05 15:55:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-09-05 15:55:50 +0200
commit51072ed8ac5f42143e7e5fa289fb6bf951d97a48 (patch)
tree3536a691e2eea3e75a28a4dc21111be92a7f4241 /gnu
parent0575fe681cdc2308dbe36c14bd3e905e79fe7213 (diff)
downloadguix-patches-51072ed8ac5f42143e7e5fa289fb6bf951d97a48.tar
guix-patches-51072ed8ac5f42143e7e5fa289fb6bf951d97a48.tar.gz
gnu: emacs-org-caldav: Update to 0.0.0-1.
* gnu/packages/emacs-xyz.scm (emacs-org-caldav): Update to latest commit, since there is no release yet. [description]: Remove alpha status, no longer specified in README.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm47
1 files changed, 25 insertions, 22 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1cf66942e5..204cb1caf9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13818,28 +13818,31 @@ be changed by customizing the appropriate variables.")
(license license:gpl3+)))
(define-public emacs-org-caldav
- (package
- (name "emacs-org-caldav")
- (version "20180403")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dengste/org-caldav/raw/"
- "8d3492c27a09f437d2d94f2736c56d7652e87aa0"
- "/org-caldav.el"))
- (sha256
- (base32
- "1fh4gh68ddj0is99z2ccyh97v6psnyda61n2dsadzqhcxn51amlc"))))
- (build-system emacs-build-system)
- (propagated-inputs `(("emacs-org" ,emacs-org)))
- (home-page "https://github.com/dengste/org-caldav")
- (synopsis
- "Sync Org files with external calendars via the CalDAV protocol")
- (description
- "Synchronize between events in Org-mode files and a CalDAV calendar.
-This code is still alpha.")
- (license license:gpl3+)))
+ (let ((commit "a563500c9884f38ce08793e2964f8274adde163d"))
+ (package
+ (name "emacs-org-caldav")
+ (version (git-version "0.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dengste/org-caldav.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18qi1iv5dc0gsvkv9ifal3cjpm568nlb907v8a53cnm4439x1l0l"))))
+ (build-system emacs-build-system)
+ (arguments
+ ;; Tests require to have two specific calendars on a test server.
+ `(#:exclude '("^org-caldav-testsuite\\.el")))
+ (propagated-inputs
+ `(("emacs-org" ,emacs-org)))
+ (home-page "https://github.com/dengste/org-caldav")
+ (synopsis "Sync Org files with external calendars via the CalDAV protocol")
+ (description "Synchronize between events in Org files and a CalDAV
+calendar.")
+ (license license:gpl3+))))
(define-public emacs-zotxt
(package