summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 08:53:33 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commitf787e9fd4ce9debb3d500cd46a8a939f7f4fc6d5 (patch)
treed9af21ba8ce660a421e9e515f8f02e213d432d28 /gnu
parentd39e82548b978d9adc2a7730cda425f539b68ed7 (diff)
downloadguix-patches-f787e9fd4ce9debb3d500cd46a8a939f7f4fc6d5.tar
guix-patches-f787e9fd4ce9debb3d500cd46a8a939f7f4fc6d5.tar.gz
gnu: Add Context-Preserve.
* gnu/packages/perl.scm (perl-context-preserve): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b9275a95fd..7dffe035c6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -634,6 +634,29 @@ supports XML, YAML, JSON, Apache-style configuration, and Perl code.")
opportunities to Perl developers as GNU Autoconf does for Shell developers.")
(license (package-license perl))))
+(define-public perl-context-preserve
+ (package
+ (name "perl-context-preserve")
+ (version "0.01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/J/JR/JROCKWAY/"
+ "Context-Preserve-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0gssillawjknqks81x7fg7w2x94bnyklgd8ry2pr1k6ifkjhwz46"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)
+ ("perl-test-simple" ,perl-test-simple)))
+ (home-page "http://search.cpan.org/dist/Context-Preserve")
+ (synopsis "Preserve context during subroutine call")
+ (description "This module runs code after a subroutine call, preserving
+the context the subroutine would have seen if it were the last statement in
+the caller.")
+ (license (package-license perl))))
+
(define-public perl-cpan-meta-check
(package
(name "perl-cpan-meta-check")