summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 12:08:40 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:15 -0500
commitf397c306e45090abd6ca00e50325af4069faf93e (patch)
tree7889d5a2c16d44dc8df4d6a1827bbaa7744b938a /gnu
parent393ca946219ed6bc84d6d27b7c68ada18f71e5bd (diff)
downloadguix-patches-f397c306e45090abd6ca00e50325af4069faf93e.tar
guix-patches-f397c306e45090abd6ca00e50325af4069faf93e.tar.gz
gnu: Add Text-Balanced.
* gnu/packages/perl.scm (perl-text-balanced): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index e166ae04e7..fdb1c823f2 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3193,6 +3193,25 @@ installed.")
generation of tests in nested combinations of contexts.")
(license (package-license perl)))) ;See LICENSE
+(define-public perl-text-balanced
+ (package
+ (name "perl-text-balanced")
+ (version "2.02")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ "Text-Balanced-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1d3mba2sjpp044h16pkf231cksa34ripaz6rmgxp0ygpl917az57"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Text-Balanced")
+ (synopsis "Extract delimited text sequences from strings")
+ (description "The Text::Balanced module can be used to extract delimited
+text sequences from strings.")
+ (license (package-license perl))))
+
(define-public perl-text-diff
(package
(name "perl-text-diff")