summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-13 12:10:02 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-13 13:52:16 -0500
commitdd90952ebe434c2f3f232af78bd8ca10ee5571df (patch)
tree62be37203c7f3b39d441355bda52de0c7e470cfd /gnu
parentf397c306e45090abd6ca00e50325af4069faf93e (diff)
downloadguix-patches-dd90952ebe434c2f3f232af78bd8ca10ee5571df.tar
guix-patches-dd90952ebe434c2f3f232af78bd8ca10ee5571df.tar.gz
gnu: Add SQL-Abstract.
* gnu/packages/databases.scm (perl-sql-abstract): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 26df1f7d22..59c8995299 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -326,6 +326,37 @@ module, and nothing else.")
(license (package-license perl))
(home-page "http://search.cpan.org/~ishigaki/DBD-SQLite/lib/DBD/SQLite.pm")))
+(define-public perl-sql-abstract
+ (package
+ (name "perl-sql-abstract")
+ (version "1.81")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
+ "SQL-Abstract-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17sgwq3mvqjhv3b77cnvrq60xgp8harjhlnvpwmxc914rqc5ckaz"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-deep" ,perl-test-deep)
+ ("perl-test-exception" ,perl-test-exception)
+ ("perl-test-warn" ,perl-test-warn)))
+ (propagated-inputs
+ `(("perl-hash-merge" ,perl-hash-merge)
+ ("perl-moo" ,perl-moo)
+ ("perl-mro-compat" ,perl-mro-compat)
+ ("perl-text-balanced" ,perl-text-balanced)))
+ (home-page "http://search.cpan.org/dist/SQL-Abstract")
+ (synopsis "Generate SQL from Perl data structures")
+ (description "This module was inspired by the excellent DBIx::Abstract.
+While based on the concepts used by DBIx::Abstract, the concepts used have
+been modified to make the SQL easier to generate from Perl data structures.
+The underlying idea is for this module to do what you mean, based on the data
+structures you provide it, so that you don't have to modify your code every
+time your data changes")
+ (license (package-license perl))))
(define-public unixodbc
(package